Ron,
Your enhancments to David's original text do appear to improve
the readability of the information. I would like to propose a
way to perhaps further improve the readability.
Right now, each component that makes up a chChannelInformation value
(ie, an "entry" or "keyword") is specified in terms of these dimensions
(using SMI-like dimension names):
Title Brief description phrase, eg: "Port name", "Service Name"
Name The keyword value, eg: "PORT", "SERVICE"
Syntax The encoding of the keyword value, eg: "2501", "ps1"
Status Either "Mandatory" or "Optional"
Multiplicity Either "Single" or "Multiple" to specify whether the keyword
can be present one or more times in the value string.
Description Helpful information describing the use of the keyword.
(The dimension name "Multiplicity" is a bit strange, I'll admit, but I can't
seem to find a better name. Suggestions?)
In your last message you proposed the following text for the "chDECLAT"
channel type's chChannelInformation value:
chDECLAT(32), -- ...
-- prtChannelInformation entries:
-- port name, optional single value
-- Format: PORT=name
-- service name, optional single value
-- Format: SERVICE=name
-- Exactly one of port and service must be
-- specified.
Using the dimension names proposed above, the text could be reformatted
as follows; note that the "Title" dimension is not explicitly tagged as
are the other dimensions:
chDECLAT(32), -- ...
-- prtChannelInformation keywords:
-- Port name
-- Name: PORT
-- Syntax: Name
-- Status: Optional
-- Multiplicity: Single
-- Description: LAT port name for job submissions
--
-- Service name
-- Name: SERVICE
-- Syntax: Name
-- Status: Optional
-- Multiplicity: Single
-- Description: LAT service name for job
-- submissions
--
-- Exactly one of PORT and SERVICE must be
-- specified.
Does this format improve the readability of the related prtChannelInformation
data?
...jay